Mercedes x class - coolant loss - Mercedes X-Class Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-14-2020, 08:42 PM Thread Starter
Junior Member
 
Join Date: Mar 2020
Posts: 1
Mercedes x class - coolant loss

Hello

I bought a new X class. All good and well until , at 2800 km, the engine yellow check engine light came on. Got the car to the service, they said the car had a low coolant level, so they completed the coolant and they said the light came off. Now at 5500 km, the same problem : the light come, i looked at the coolant : under the minimum level ! So guys, any ideas ? Did anybody else had this problem ? I never had this problem to a new 5000 km car ! Because of this issue, I am totally disappointed by this car. Thank-you.
clauteo is offline  
post #2 of 2 (permalink) Old 03-17-2020, 07:58 AM
Junior Member
 
Join Date: Dec 2019
Location: Tasmania Australia
Posts: 7
Garage
Hey Clauteo,

Interesting issue, I've never personally had or known anyone who has had this issue. Is it the V6 or 4?

TH
TheHammer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes X-Class Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome