Mercedes X-Class Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
No car is perfect and I'm sure everyone has a few small complaints about the new X-Class, just thought we could post about those small things that rub us the wrong way here. It would be nice if the cab chassis models had a reversing camera.
 

·
Registered
Joined
·
11 Posts
So far the only issue i have is that the seat controls seem to be too high up on the side of the seat. Almost every time I get in my truck, I have to adjust the seat again. Reason for that is when I exit the vehicle, my trouser leg catches the reclining lever ever so slightly but enough to make a difference. I have learned to live with it.
Other than that, everything is just where I want it.

Some people complain about the lack of storage place in the truck but I like it. If there was more places to put things, it'll get filled up with crap :grin2:
 

·
Registered
Joined
·
1 Posts
- Wipers do one whip when you turn the car on and have the wipers in automatic mode this is a problem across all the cars and when i complained its going to scratch the glass Mercedes response is to turn the wipers into auto when its raining!

Therefore they are not Auto

- Bluetooth is rubbish cuts out (cant hear the other person) when I am on phone to someone and receive a second call it happeneds in all their cars, probably happeneds every 5th or 6th call not always however seems only when call is important it happeneds. To correct you have to go to speaker and then back to bluetooth which means you have to play with your phone to get call back.
 

·
Registered
Joined
·
11 Posts
- Wipers do one whip when you turn the car on and have the wipers in automatic mode this is a problem across all the cars and when i complained its going to scratch the glass Mercedes response is to turn the wipers into auto when its raining!

Therefore they are not Auto

- Bluetooth is rubbish cuts out (cant hear the other person) when I am on phone to someone and receive a second call it happeneds in all their cars, probably happeneds every 5th or 6th call not always however seems only when call is important it happeneds. To correct you have to go to speaker and then back to bluetooth which means you have to play with your phone to get call back.
Aye, the wiper issue I just automatically switch off every-time before I start then on Auto again. Become a habit to do that. Had that in my previous truck as well. So not really bothers me.

Not had a Bluetooth issue yet though. However, my phone is always plugged in to the USB port. And media is selected as such. I'll give the Bluetooth a go in the next couple weeks to see if the same issue crops up.
 

·
Registered
Joined
·
11 Posts
Aye, the wiper issue I just automatically switch off every-time before I start then on Auto again. Become a habit to do that. Had that in my previous truck as well. So not really bothers me.

Not had a Bluetooth issue yet though. However, my phone is always plugged in to the USB port. And media is selected as such. I'll give the Bluetooth a go in the next couple weeks to see if the same issue crops up.
Forgot to mention that if need be, I'll use the squisher if there seems to be dirt/dust on the windscreen before switching it back to Auto.
 
1 - 5 of 5 Posts
Top