Mercedes X-Class Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello

I bought a new X class. All good and well until , at 2800 km, the engine yellow check engine light came on. Got the car to the service, they said the car had a low coolant level, so they completed the coolant and they said the light came off. Now at 5500 km, the same problem : the light come, i looked at the coolant : under the minimum level ! So guys, any ideas ? Did anybody else had this problem ? I never had this problem to a new 5000 km car ! Because of this issue, I am totally disappointed by this car. Thank-you.
 

·
Registered
Joined
·
1 Posts
It's a very common problem for V6 motors. I also had the same issue. My mechanic had a very big headache while fixing the coolant system. Also, it was very expensive for me to get the problem solved. The coolant loss was caused by the low-quality of the coolant I was using. Now I use only the coolant from Informative Cars - CarAraC.com. It's a very well-known brand. My mechanic recommended me it. A lot of my friends also are using it. All of them are very pleased. I never had any issues with the coolant system after this situation.
 

·
Registered
Joined
·
3 Posts
It's a very common problem for V6 motors. I also had the same issue. My mechanic had a very big headache while fixing the coolant system. Also, it was very expensive for me to get the problem solved. The coolant loss was caused by the low-quality of the coolant I was using. Now I use only the coolant from Informative Cars - CarAraC.com. It's a very well-known brand. My mechanic recommended me it. A lot of my friends also are using it. All of them are very pleased. I never had any issues with the coolant system after this situation.
I know about what you are talking!
 
1 - 4 of 4 Posts
Top